GitHub header

Delayed GitHub Actions Jobs

Incident Report for GitHub

Resolved

On May 22, 2025, between 07:06 UTC and 09:10 UTC, the Actions service experienced degradation, leading to run start delays. During the incident, about 11% of all workflow runs were delayed by an average of 44 minutes. A recently deployed change contained a defect that caused improper request routing between internal services, resulting in security rejections at the receiving endpoint. We resolved this by reverting the problematic change and are implementing enhanced testing procedures to catch similar issues before they reach production environments.
Posted May 22, 2025 - 09:17 UTC

Update

We've applied a mitigation which has resolved these delays.
Posted May 22, 2025 - 09:17 UTC

Update

Our investigation continues. At this stage GitHub Actions Jobs are being executed, albeit with delays to the start of execution in some cases.
Posted May 22, 2025 - 08:47 UTC

Update

We are continuing to investigate these delays.
Posted May 22, 2025 - 08:14 UTC

Update

We're investigating delays with the execution of queued GitHub Actions jobs.
Posted May 22, 2025 - 07:43 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted May 22, 2025 - 07:42 UTC
This incident affected: Actions.